Gracias por comentar.

Este Blog cuenta con detección automática de spam para los comentarios. Además, hasta que yo no los lea no se publicaran...

Buscar en este blog

viernes, 11 de noviembre de 2011

Instalar Avant Window Navigator en Linux Mint Debian Edition

Una de las cosas que siempre instalo es el dock Avant Window Navigator (AWN). Pero en LMDE no funciona bien. Muchos de sus applets (Miniaplicaciones) no funcionan. En su lugar aparece algo que parece una cara triste...

En Ubuntu Cosillas he visto la forma de solucionarlo. Que es instalar la versión Trunk de AWN:

Para esto lo que necesitamos son los repositorio de Lucid que son los equivalentes y los cuales cumplen con todas sus dependencias.
Abrimos desde el terminal el archivo Sources.list


sudo gedit /etc/apt/sources.list


Al final añadimos las siguientes líneas:

#AWN Trunk
deb http://ppa.launchpad.net/awn-testing/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/awn-testing/ppa/ubuntu lucid main 


Actualizamos:

sudo apt-get update


Nos dará un error de Key ya que no ha sido añadida.
Ahora os voy a enseñar el método que yo utilizaba antes de que Ubuntu mejorar y automatizara el método de añadir las Keys de seguridad.

Cuando nos da este error no muestra una serie de dígitos de los cuales tan sólo debemos tener en cuenta los 8 últimos.
Ejemplo del error:

Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 9887DCE9XXXXXXXX

Escribimos en el terminal:


PUBKEY=xxxxxxxx



Las x representan a esos 8 últimos números.
Pulsamos intro, y añadimos las siguientes líneas una a una:


gpg --keyserver subkeys.pgp.net --recv-key $PUBKEY
gpg -a --export $PUBKEY | sudo apt-key add -
sudo apt-get update

Nota: no se porque las "&" se me convierten en &amp por lo tanto si queremos hacerlo con un solo comando ir a la fuente original...


Las cuales se encargaran de instalarnos la Signing Key

Luego:


sudo apt-get install avant-window-navigator-trunk

Si tenemos ya instalada la anterior versión no indicará que confirmemos para eliminarla.


Pues nada, ahora ya funciona mi Avant al 100% en LMDE.

A mi me quedo asi:



Nota:
Hace unos días que no funciona el Aplet o Miniaplicacion del Clima. Hoy mismo lo solucione con las pistas que me dieron en esta pagina: http://www.ubuntu-es.org/node/88517 su solución no funciona en LMDE pero, bueno, dan pistas.

Para solucionarlo, en LMDE, editamos el archivo weathertext.py como administrador. Ponemos en un Terminal:

sudo gedit /usr/share/avant-window-navigator/applets/weather/weathertext.py


Buscamos (con Ctrl + f) en el archivo que se nos abre:

prod=xoap&par=


Y cambiamos la linea para que quede asi:


__ws_key = "&prod=xoap&par=1003666583&key=4128909340a9b2fc&link=xoap"

lo principal es 10036665834128909340a9b2fc el resto igual...

(Las & me estan amargando...  (al final resuta que Blogger las muestra mal cuando estas escribiendo la entrada pero luego, cuando publicas, se ven bien los comandos...)).

Cerramos AWN, lo volvemos a abrir y ya funciona la Miniaplicacion, incluso con prediccion para 5 dias...


Ahora a disfrutarlo.

Por cierto, la nueva interfaz de bloger me esta amargando, (en mi PC, en el portatil va bien). Que cantidad de fallos para hacer la entrada, no veo ni los botones para editar la entrada, negrita, color... estan detras de la entrada, me mete espacios donde no hay, la correcion ortografica, un coñazo... Tal vez sea por mi monitor... A ver si puedo volver a la version antigua...

Fuentes:

11/11/11

Hoy es 11/11/11: la fecha capicúa que ocurre cada 100 años


viernes, 4 de noviembre de 2011

Sobre Linux Mint 12

Aclarariones de la gente de Linux Mint sobre lo que puede ser Linux Mint 12, “Lisa” (el enlace traducción de The Linux Mint Blog).

http://www.com-sl.org/declaraciones-de-clem-acerca-del-rumbo-de-linux-mint-12.html


Toca esperar hasta que salga y ver si vale la pena...